Friday, May 23, 2008

Blog not properly displayed in Firefox

Recently, without a warning, my blog site stopped being properly displayed, when drilling down on the circumstances that prevented it from properly displaying at least, so far, I have found that when it is displayed with Firefox browsers the left navigation bar 'disappears'. If displayed with Internet Explorer it is properly displayed.

I had not realized about this fact, but when Eduardo Legatti asked me what happened with the left navigation bar it was when I entered as a regular non authenticated user, I saw something happened with my Blog Archive and my Topics menus, those were gone. Eduardo told me he uses also Firefox.

In my personal opinion my default choice is Firefox, just like 24% of the blog users, not Internet Explorer, unless due to VPN restrictions or bank access requirement. I have tried to change my layout, and unsuccessfully it behaves the same. So the workaround in the mean time is to click on the item menu or use Internet Explorer :(

Some people have reported differences between firefox and internet explorer [Resolving Browser Display Discrepancies Between IE and Firefox].

... After a couple of hours after publishing this post the left navigation bar is back again, it looks like there was some issue wiht the cache. I have removed the cache from firefox, but I am not sure this was the actual solution.

4 comments:

Aman Sharma said...

Madrid,
I am not sure.Neither I use Firefox as for me its very slow and eats my RAM like I eat chocolats nor IE(no reason ).I user opera and I didn't find any issues with the navigation bar.I didnt check at that time when Legatti had issues but I never faced any issues myself.
Thought will give you feedback about user of Opera too;-).
Regards
Aman....

Eduardo Legatti said...

Great! Currenlty, it is working perfectly in Firefox. Let's see what will happen for now on ...

Cheers

Legatti

Hector Rivera Madrid said...

Thank you very much guys! There it appear to be some differences between browsers, which doesn't happen to be too much surprising. Opera is a browser I have not tried, but I should give it a chance. I am very used to Mozilla, since this happened to be the browser less prone to viruses and malware. I try as much as possible to avoid using Internet Explorer. I have seen several strange behaviors when using IE7 and EM DB Control, so this, among other bad experiences, have made me choose another browser different from the MS Option.

Aman Sharma said...

Madrid,
Opera IMO is very nice browser with lots of features.Yet its not supported by many sites :-(.Also EM is not supported for this browser.But it is advertised as "world's fastest browser" and as per my experience, I do see it very fast as comparable to IE or Mozilla.Worth a try atleast :-).
Regards
Aman....